Announcement

Collapse
No announcement yet.

S160 - Impossible to turn on - Megane III

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • S160 - Impossible to turn on - Megane III

    Hello Everyone,
    My name is Nicolas, I'm French, and this is my first topic on this forum because I bought a S160 for my Megane III Carminat TomTOm year 2010.

    I received it 2 days ago and I installed it the same day but it doesn't work.

    When I finished to plug everything, the SRC button was lit in red, the renault logo was displayed on the screen during 3 or 4 secondes, then the screen turned off, the head unit makes a "beeep" sound, then the SRC button turn off.

    I have the exact same problem than on this video : https://www.youtube.com/watch?v=wekszHCqe7s

    I checked on this great forum and I saw this topic : https://www.roadnav.com/forum/help-a...will-not-start
    Do you think it could be the same problem of wires ?
    I didn't checked with a multimeter but they seems to be connected in the right place.

    I also have another question. I have 2 similars cables but with a different "socket" : one in Fakra and one another that I've never seen (the circled red on the attached picture).

    Do you know what I have to do with this one ? I think it is not for my car ...

    Thank you for your help.
    Last edited by Nicavo; 07-28-2016, 13:46.

  • #2
    Hi, to me the circled connector looks like the one going to the car's loom, but I guess you tried that already.

    However, if the SRC button is turned off, the ACC signal is gone. Without that there is no power going to the unit. It's also worth checking the right layout of all the pins. On mine the antenna amplifier was connected to the illumination socket. If you have the possibility, try the radio on your desk. You need to supply battery and ACC with 12V and GND with, erm, GND. If the unit starts, you have to check the voltages in your car. The important thing is, that ACC and Battery are in the right place. Sometimes they are switched on the car's loom.

    Comment


    • #3
      Hi Subaru_driver !

      The circled connector maybe looks like the one going to the car's loom but not for a megane (because megane loom is a fakra one).

      When I tried it in my car, I used the left cable, not the right one.
      Because they are similar except 2 points :
      - The car's loom (one in fakra and one I don't know)
      - The left one have a part for the antenna, not the right one
      And I only have one canbus box.

      It's interresting to know that if the SRC button is turned off, that's the ACC signal gone. I don't have any solution to check the unit on my desk because it would need a fakra connector.
      I will check it with a multimeter in my car this week end.

      Thank you for your answer.

      Comment


      • #4
        Thank you Subaru_driver,
        I plugged the ACC cable on the +12v of my lighter and the autoradio finally works !!!
        The Fakra connector of the Megane 3 doesn't have a ACC +12V.

        Now I have another problem : the canbus box is not detected. I double checked and it is well plugged...

        -> SWC doesn't work
        -> The temperature is 0°C
        -> The belt light doesn't work
        -> The passenger airbag light doesn't work
        I think the canbus box is not working : I tried to disconnect it and turn on the autoradio, it is exactly the same.





        I have an error message on my OBD because of the passenger airbag, but it is because the old screen have a plug which I can't connect on the new one :



        Do you think the canbus is broken ?

        Thank you.

        Comment


        • #5
          Hi Nicolas,

          I'm french too. I have a Megane 3 2011 with Carminat Tomtom.
          I have exactly the same problem... And I still not found a solution...

          The cables supplied with the S160 are not appropriate to the wiring harness of the car.
          Last edited by Thom@s; 08-04-2016, 13:48.

          Comment


          • #6
            Hi,
            sorry for the late reply, I didn't have sufficient web access.
            However, I can't give you detailed support regarding CAN-Bus decoders, since I didn't have one. Maybe Leigh63 knows more about that. But I do know, that there're different models available and some users had the wrong device delivered with their headunit. I think you have to check this with your dealer anyway.
            There is also an App available, which is called "RK3188 HeadUnit" and this one sometimes solves issues that are CAN-Bus related.
            Regarding the ACC supply, you have to take care, that the power supply is switched off when you leave the car. Otherwise the radio will drain your battery. I would suggest to use either terminal 15 (ignition), or you create your own ACC signal, like it is done for sub-woofers, by using a relay box.
            Btw. maybe your CAN-Bus decoder also needs to be connected to the ACC signal.
            Last edited by Subaru_driver; 08-05-2016, 16:27.

            Comment


            • #7
              Hi Subaru_driver.
              Thank you for your answer.
              -> I will try "RK3188 HeadUnit" app, I will let you know.
              -> For the ACC supply, I can assure you that we didn't have the choice ! There is no ACC on megane III... But the Lighter of Megane III sitch off 1min after leave the car so the battery won't be damaged.
              -> I don't understand what is the ignition wire on terminal 15 ?
              -> If our can-bus decoder need to be connected to acc signal, I need to know on wich terminal. Do you know where I can find the electric map of my can-bus decoder ?

              Thank you.

              Comment


              • #8
                Hi,
                ok, if your lighter is connected to a switched voltage supply it's fine. The "terminal 15" is the voltage supply that is switched on, if you turn your key to "On" and switched off immediately after you turned your key back. So the way you found is much more comfortable.Regarding the CAN Bus decoder I had another thought and it has to be supplied via the cable that came with it, anything else won't make sense. You can use the search of the forum to get more information about the different CAN Bus decoders around. I think there were some issues with Opel/Vauxhall and Ford cars. Just make sure, that you're looking at the S160. But I think the App is a good start.

                Regarding the terminals: These are standardised as T15 is Ignition, T30 is battery +12V and T31 is GND. It is a common naming regardless of the actual schematics of your car.

                Comment


                • #9
                  Hi Subaru_driver.

                  I tried RK3188 HeadUnit app but it doesn't work.

                  And Yes I can't assure you this is a S160.

                  I'm really stuck with this canbus non working ...

                  Comment


                  • #10
                    Hi,

                    I found out that all the looms of Megane III with GPS (tomtom) doesn't carry the same informations than the looms of Megane III without GPS...

                    That's why I can't make the S160 functionnal with my car.

                    If someone found a solution, please contact me.

                    Comment


                    • #11
                      Maybe you can find the wiring schemes for your car on the internet, or you can buy a workshop manual, or if you ask kindly, your dealer will print it for you. Essentially what you need is the pin-out of the car's connector going to the S160. This should be possible. For my car I was able to buy a workshop manual on ebay.

                      Comment


                      • #12
                        Hi Subaru_driver,

                        I give some news about our problems.

                        With Nicavo, we found the original connector going to the S160. (Number 653)

                        This is wiring scheme for Megane 3 without GPS




                        Here is the original connector (Megane 3 without GPS) with pin used by S160 plug. Colored pins are those that are used.



                        After some research, we found a connector using almost the same informations on our Megane 3 with Carminat TomTom. (Number 1714)



                        Information about 1714 connector (Megane 3 with Carminat TomTom)



                        Nicavo has plugged this connector on the S160 plug and almost everything seems working well !
                        I have not been able to do this because I need a specific tool to remove the odometer. Connector is behind odometer...

                        SWC is very buggy and do not work properly but it's possible to assign button. (Vol+, etc..)
                        I think we should try to bypass the CanBus Decoder but we have not enough informations for trying this...

                        Comment


                        • #13
                          Operation done.



                          SWC works correctly for me with predefined buttons but impossible to assign any touch from the SWC program.

                          Does anyone can confirm that is normal with S160 on M145 ?

                          Comment


                          • #14
                            I confirm that we made exactly sthe same operation with Thom@s and we don't have the same resultats.
                            When he told me that the swc works in his car and the screen display "canbus connect success", I tried to unplugg all connections of the s160 and replug them correctly ... but it doesn't change anything. SWC doesn't work properly.
                            When I push the + button for example, sometimes the volume increase of 1 point then it is muted. But sometimes it works normally. And someother it doesn't works at all.
                            When I push the mute button sometimes it works sometimes it doesn't.
                            When I push the src button of the swc, sometimes it switch apps, sometimes it mutes everything, sometimes it doesn't work at all.
                            ... Like the SWC actions are crazy !

                            I don't understand where is the problem if it works for Thom@s. Maybe my canbus box is not good ?

                            Comment


                            • #15
                              I'm using an S160 M145, Megane 3 model without GPS and I have a problem with my SWC. When I switch on the car everything works properly, but after some minutes it stops working and then after some other time it comes back to normal. This happens with the stock ROM and with Kotix ROM too.
                              What could the problem be? Maybe a faulty canbus decoder?

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X