Announcement

Collapse
No announcement yet.

S100 Firmware Update Instruction

Collapse
This is a sticky topic.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • S100 Firmware Update Instruction

    1. Preparation A blank SD/Mini SD card

    Capacity: 1G/2G
    Format: FAT32
    NOTICE: The update work will last 15 minutes, do not press any buttons or icons (except for calibrating screen) or power off the unit during the process.

    A. Download the S100 firmware for your model here RN S100 WinCE Firmware Update
    B. Unzip with an archive program that will extract Chinese characters for the folder & filenames.
    C. Copy the files into the root directory of the SD card. Be sure you have Chinese characters .Like this: 版本号.txt (not like this: ¦µ¦¥¦+.txt)

    2. Patch Update :
    Note: Skip this step if you cannot access to the system OS. Proceed to Step 3 – Firmware Update. You will able to access system after finishing step 3, then re-do the update per this instruction.

    File structure will be like this for new firmware (note: BTUpdate folder is not required in newer firmwares)

    s100-firmware-file-structure.png

    A. Turn on RoadNav S100 GPS unit
    B. Insert the firmware card into MAPS (GPS) card slot
    C. Setup the GPS path: \patch\UpgradePatch.exe
    D. Back to the main interface and press GPS/Navi icon
    E. Screen shows “Patch OK!”, done!
    Note: it means you already have the latest patch if you get error "patch is forbidden".

    3. Firmware Update:

    A. Insert firmware card into GPS slot. Reboot system, firmware will be updated automatically.

    B. Upgrade Eboot and NK, the screen will be red:

    S100_Firmware_Update_Red_Screen.png

    C. Calibrate the screen:

    S100_Firmware_Update_Calibrate_Screen.png

    D. Copy the apps:

    S100_Firmware_Update_Coping_Files.png

    E. Upgrade flash. Screen goes into black/blink interface and beep for around 3 minutes.

    S100_Firmware_Update_Flash.png

    F. It will display “Complete 100%” and “**Mission Accomplished! Please pull out of the card!”. Remove the SD card, the unit will restart automatically.

    S100_Firmware_Update_Complete_Screen.jpg

    G. DONE!
    Last edited by Leigh63; 01-05-2017, 11:15 AM.

  • #2
    Hello,
    I tried to update my Opel Astra C072I following your instruction but now I can see:

    WARNING
    Illegal update package, upgrade terminated!
    Please contact your local dealer!

    If I try to update the firmware a RED screen say:
    ERROR: Upgrade package does not match!
    Halting...

    What can I do, now????

    ************************************************** *************************************
    Ok, SOLVED!
    1. open "update.ini" into "image" folder
    2. add a new line: oeminfo=HFZ
    3. save
    4. update firmware

    Last edited by maxetere; 04-03-2014, 08:45 AM. Reason: SOLVED

    Comment


    • #3
      Hi Maxetere, thanks for solution. The best way is like this

      1. make sure you have removed the firmware card before starting
      2. restart system
      3. insert firmware card
      4. go to setting, setup GPS path to \patch\UpgradePatch.exe
      5. back to main screen, click Navi. it reminds patch is updated
      6. restart to update firmware, you won't have the illegal issue now.

      Comment


      • #4
        Uhm... but "UpgradePatch.exe" is only necessary to restart the system or make changes?

        Comment


        • #5
          HI, ROADNAV
          I tried to update my Peugeot 207 c207I following your instruction with the latest your firmware but :

          WARNING
          Illegal update package, upgrade terminated!
          Please contact your local dealer!

          When i try to patch the system a message appear : patch is forbidden

          There is my system spec:

          bsp: s100-uni.f201140106-a2.1
          app: s100-v1.0.9.18
          mcu: f00k s00b c207
          dvd: 3227 v100 7706
          bt: 20121204
          oem info : a008

          What can I do????

          THANKS

          Comment


          • #6
            Dear RoadNav
            When I turn on the DVD S100, on display show only Renault logo
            Could you please send me firmware for car OEM S100 ( tip- oct.2013 ) for car Renault Megane III -2009 model

            Thank in advance

            Comment


            • #7
              Dear RoadNav
              more info for system
              Last edited by MB67; 04-10-2014, 10:54 PM.

              Comment


              • #8
                Hi Roadnav,

                I tried to upgrade my C078 unit with the firmware you gave me but I got "Illegal update package, upgrade terminated!"
                Please contact your local dealer!
                and now no way to get the unit working again!

                No way to get main screen, I cannot do nothing!

                I tried to remove the firware update card and restart the unit but it does not work

                How I can reset the unit ?

                Comment


                • #9
                  ciao roadnav,
                  sa dirmi se esiste un firmware c047 s-100 per la mia ix 35 aggiornato al 2014? grazie per la cortesia

                  Comment


                  • #10
                    Добрый день. Мне необходимо обновить Winca S100 (C098), Renault Megane 2 (2002-2008). Сейчас у меня APP:S100-V1.1.9.0 Нужна новая версия прошивки. Пожалуйста пришлите ее мне на электронную почту andrei_logachev@mail.ru Спасибо.

                    Comment


                    • #11
                      Hi,

                      since i upgrade with new firmware all is ok except the GPS.
                      I route the igo8.exe but s100 says program data invalid or something like that ....
                      Can you help me ?

                      thanks

                      Comment


                      • #12
                        Is there any method to downgrade S100 to previous version of firmware?

                        Comment


                        • #13
                          Hi RoadNav

                          Thanks for your help and assistance. I have a Holden Colorade ute, and will appreciate some answers for the following:

                          1. I had some issues with my unit, and was sent a C203I "upgrade", with APP Edition S100-V1.1.9.0. Is this the latest firmware? This is my system spec:






                          2. I tried to update this with a C203 version with APP Edition S100-V1.1.9.18, but I get the same warnings as Wallahoo above:

                          WARNING Illegal update package, upgrade terminated!
                          Please contact your local dealer!

                          When i try to patch the system a message appear : patch is forbidden

                          Can you please help?

                          Many thanks

                          Eddie

                          Comment


                          • #14
                            Hi all,

                            I tried to download the firmware for my Rrenault Megane (C145), but I need to fill in a password first. Can everybody tell me the password?

                            Thank you in advance!

                            cytidin

                            Comment


                            • #15
                              Good morning, I have the C083 core for Peugeot 408 with S60 software. You can upgrade to the S100? thank you

                              Comment

                              Working...
                              X